summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 8d2f1d57b3..330675f8f3 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -87,17 +87,18 @@
     (inputs
      `(("readline" ,readline)))
     (arguments
-     `(#:tests? #f ;no tests
+     `(#:make-flags
+       (list ,(string-append "CC=" (cc-for-target)))
+       #:tests? #f                      ; no tests
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'set-env
+         (add-after 'unpack 'patch-file-names
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (substitute* "Makefile"
                (("/usr/local/bin")
                 (string-append (assoc-ref outputs "out") "/bin"))
                (("/usr/local/opt/readline")
                 (assoc-ref inputs "readline")))
-             (setenv "CC" "gcc")))
          (delete 'configure))))
     (build-system gnu-build-system)
     (home-page "https://github.com/six-ddc/hss/")