summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/gvpe.scm48
2 files changed, 49 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 616853591d..3497bf1b53 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -88,6 +88,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/gtk.scm				\
   gnu/packages/guile.scm			\
   gnu/packages/gv.scm				\
+  gnu/packages/gvpe.scm				\
   gnu/packages/help2man.scm			\
   gnu/packages/hugs.scm				\
   gnu/packages/icu4c.scm			\
diff --git a/gnu/packages/gvpe.scm b/gnu/packages/gvpe.scm
new file mode 100644
index 0000000000..1018428306
--- /dev/null
+++ b/gnu/packages/gvpe.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gvpe)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:select (gpl3+))
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages openssl)
+  #:use-module ((gnu packages compression) #:select (zlib)))
+
+(define-public gvpe
+  (package
+    (name "gvpe")
+    (version "2.25")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gvpe/gvpe-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1gsipcysvsk80gvyn9jnk9g0xg4ng9yd5zp066jnmpgs52d2vhvk"))))
+    (build-system gnu-build-system)
+    (home-page "http://software.schmorp.de/pkg/gvpe.html")
+    (inputs `(("openssl" ,openssl)
+              ("zlib" ,zlib)))
+    (synopsis "Secure VPN among multiple nodes over an untrusted network")
+    (description
+     "The GNU Virtual Private Ethernet creates a virtual network
+with multiple nodes using a variety of transport protocols.  It works
+by creating encrypted host-to-host tunnels between multiple
+endpoints.")
+    (license gpl3+)))