summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6d8ab71c78..04625827c5 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -355,7 +355,15 @@ without requiring the source code to be rewritten.")
                (lambda _
                  ;; Remove this test that's bound to fail.
                  (delete-file "test-suite/tests/version.test")
-                 #t)))))))))
+                 #t))))))
+      (native-search-paths
+       (list (search-path-specification
+              (variable "GUILE_LOAD_PATH")
+              (files '("share/guile/site/3.0")))
+             (search-path-specification
+              (variable "GUILE_LOAD_COMPILED_PATH")
+              (files '("lib/guile/3.0/site-ccache"
+                       "share/guile/site/3.0"))))))))
 
 (define (make-guile-readline guile)
   (package