summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index f4fece302b..c3f354e590 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -307,3 +307,27 @@ processes.")
 compression format.")
       (home-page "https://github.com/golang/snappy")
       (license bsd-3))))
+
+(define-public go-github-com-jackpal-gateway
+  (let ((commit "5795ac81146e01d3fab7bcf21c043c3d6a32b006")
+        (revision "0"))
+    (package
+      (name "go-github-com-jackpal-gateway")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jackpal/gateway")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0fkwkwmhfadwk3cha8616bhqxfkr9gjjnynhhxyldlphixgs3f25"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/jackpal/gateway"))
+      (synopsis "Discover the address of a LAN gateway")
+      (description "@code{gateway} is a Go library for discovering the IP
+address of the default LAN gateway.")
+      (home-page "https://github.com/jackpal/gateway")
+      (license bsd-3))))