summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm2
-rw-r--r--gnu/packages/kde-plasma.scm2
-rw-r--r--gnu/packages/qt.scm4
-rw-r--r--gnu/packages/telegram.scm2
-rw-r--r--gnu/packages/video.scm2
5 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 61cbf19bc4..059667ee5d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1068,7 +1068,7 @@ protocols used in KDE Plasma.")
     (native-inputs
      (list extra-cmake-modules pkg-config))
     (inputs
-     (list qtbase-5 qtwayland wayland wayland-protocols))
+     (list qtbase-5 qtwayland-5 wayland wayland-protocols))
     (arguments
      `(#:tests? #f ; FIXME tests require weston to run
                    ; weston requires wayland flags in mesa
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 39716187fd..064f5f7278 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -177,7 +177,7 @@ call it if it is not associated to a terminal.")
      (list libxkbcommon
            qtbase-5
            qtdeclarative-5
-           qtwayland
+           qtwayland-5
            wayland
            wayland-protocols))
     (home-page "https://invent.kde.org/plasma/layer-shell-qt")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8c94d613d6..f6e5a37472 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -220,7 +220,7 @@ window managers, that don't provide Qt integration by themselves.")
        (list cmake-shared extra-cmake-modules pkg-config))
       (inputs
        `(("qtbase" ,qtbase-5)
-         ("qtwayland" ,qtwayland)
+         ("qtwayland" ,qtwayland-5)
          ("wayland" ,wayland)
          ("xkbcommon" ,libxkbcommon)))
       (synopsis "Material Decoration for Qt")
@@ -1450,7 +1450,7 @@ record media, and manage a collection of media content.  It also contains a
 set of plugins for interacting with pulseaudio and GStreamer.")
     (license (package-license qtbase))))
 
-(define-public qtwayland
+(define-public qtwayland-5
   (package (inherit qtsvg-5)
     (name "qtwayland")
     (version "5.15.2")
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 2df68ccca7..82c9227ba8 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -502,7 +502,7 @@ Telegram project, for its use in telegram desktop client.")
            qtbase-5
            qtimageformats
            qtsvg-5
-           qtwayland
+           qtwayland-5
            range-v3
            rlottie-for-telegram-desktop
            rnnoise
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 01c9ae186a..ca6148b078 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3385,7 +3385,7 @@ be used for realtime video capture via Linux-specific APIs.")
       qtbase-5
       qtsvg-5
       qtx11extras
-      qtwayland
+      qtwayland-5
       speexdsp
       v4l-utils
       wayland