summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ea76f8d00f..3cf1ffcd1f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4580,6 +4580,14 @@ sequence itself can be retrieved from these databases.")
     (arguments
      `(#:parallel-build? #f ; not supported
        #:tests? #f ; no "check" target
+       #:make-flags
+       (list (string-append "VDB_LIBDIR="
+                            (assoc-ref %build-inputs "ncbi-vdb")
+                            ,(if (string-prefix? "x86_64"
+                                                 (or (%current-target-system)
+                                                     (%current-system)))
+                                 "/lib64"
+                                 "/lib32")))
        #:phases
        (alist-replace
         'configure
@@ -4598,6 +4606,10 @@ sequence itself can be retrieved from these databases.")
             (("my \\$ilibdir = File::Spec->catdir\\(\\$builddir, 'ilib'\\);")
              "my $ilibdir = File::Spec->catdir($dir, 'ilib');"))
 
+          ;; Dynamic linking
+          (substitute* "tools/copycat/Makefile"
+            (("smagic-static") "lmagic"))
+
           ;; The 'configure' script doesn't recognize things like
           ;; '--enable-fast-install'.
           (zero? (system*