summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9c5d909f6..53d74c1719 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10262,6 +10262,26 @@ cyclomatic complexity of Python source code.")
      (list python-pycodestyle-2.6 python-entrypoints python-pyflakes-2.2
            python-mccabe))))
 
+(define-public python-flake8-blind-except
+  (package
+    (name "python-flake8-blind-except")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-blind-except" version))
+       (sha256
+        (base32 "05nxsxfzfhwsm8gys90228imm2qbnqnw5y8bfqyfngnbkmd5fnpj"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ; no tests
+    (native-inputs (list python-pycodestyle))
+    (home-page "https://github.com/elijahandrews/flake8-blind-except")
+    (synopsis "Check for blind @code{except:} statements")
+    (description "This package provides a flake8 extension that checks for
+blind @code{except:} statements.")
+    (license license:expat)))
+
 (define-public python-flake8-bugbear
   (package
     (name "python-flake8-bugbear")