summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index b9580b0d7a..1b1285d32c 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -435,20 +435,10 @@ GNU@tie{}Guile.  Use the @code{(ice-9 readline)} module and call its
                (base32
                 "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))
     (arguments
-     (substitute-keyword-arguments `(;; Tests aren't passing for now.
-                                     ;; Obviously we should re-enable this!
-                                     #:tests? #f
-                                     ,@(package-arguments guile-2.2))
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (add-after 'unpack 'autogen
-                      (lambda _
-                        (zero? (system* "sh" "autogen.sh"))))
-           (add-before 'autogen 'patch-/bin/sh
-                       (lambda _
-                         (substitute* "build-aux/git-version-gen"
-                           (("#!/bin/sh") (string-append "#!" (which "sh"))))
-                         #t))))))
+     `(;; Tests aren't passing for now.
+       ;; Obviously we should re-enable this!
+       #:tests? #f
+       ,@(package-arguments guile-2.2)))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)