summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm5
-rw-r--r--gnu/packages/java.scm5
-rw-r--r--gnu/packages/julia.scm6
3 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 82c7109316..3bb5e3074a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -111,6 +111,11 @@
        ;; We get a smaller number of test failures by disabling parallel test
        ;; execution.
        #:parallel-tests? #f
+
+       ;; The DSOs use $ORIGIN to refer to each other, but (guix build
+       ;; gremlin) doesn't support it yet, so skip this phase.
+       #:validate-runpath? #f
+
        #:modules ((guix build gnu-build-system)
                   (guix build utils)
                   (guix build rpath)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d50281839f..db730cd60e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -160,6 +160,11 @@ build process and its dependencies, whereas Make uses Makefile format.")
        ;;   made no attempts to make a list of failing JDK tests.  At least
        ;;   222 tests are failing of which at least 132 are AWT tests.
        #:tests? #f
+
+       ;; The DSOs use $ORIGIN to refer to each other, but (guix build
+       ;; gremlin) doesn't support it yet, so skip this phase.
+       #:validate-runpath? #f
+
        #:configure-flags
        (let* ((gcjdir (assoc-ref %build-inputs "gcj"))
               (ecj    (string-append gcjdir "/share/java/ecj.jar"))
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 036e485be3..e5990441f5 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -56,6 +56,12 @@
        #:modules ((ice-9 match)
                   (guix build gnu-build-system)
                   (guix build utils))
+
+
+       ;; The DSOs use $ORIGIN to refer to each other, but (guix build
+       ;; gremlin) doesn't support it yet, so skip this phase.
+       #:validate-runpath? #f
+
        #:phases
        (alist-cons-after
         'unpack 'hardcode-soname-map