summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a98971e294..a4d97fad65 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9006,6 +9006,53 @@ provides a wrapper of de novo motif discovery software.")
 This package wraps C++ code from the MOODS motif calling library.")
     (license license:gpl3)))
 
+(define-public r-chromvar
+  (package
+    (name "r-chromvar")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "chromVAR" version))
+       (sha256
+        (base32 "0dn04ijgq8fncn2bkvnd0lnabjg2s4mpb91b3kwvv3nkgjgfx819"))))
+    (properties `((upstream-name . "chromVAR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-biocparallel" ,r-biocparallel)
+       ("r-biostrings" ,r-biostrings)
+       ("r-bsgenome" ,r-bsgenome)
+       ("r-dt" ,r-dt)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-iranges" ,r-iranges)
+       ("r-matrix" ,r-matrix)
+       ("r-miniui" ,r-miniui)
+       ("r-nabor" ,r-nabor)
+       ("r-plotly" ,r-plotly)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)
+       ("r-rsamtools" ,r-rsamtools)
+       ("r-rtsne" ,r-rtsne)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-shiny" ,r-shiny)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)
+       ("r-tfbstools" ,r-tfbstools)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/release/bioc/html/chromVAR.html")
+    (synopsis "Determine chromatin variation across regions")
+    (description
+     "This package @code{r-chromvar} determines variation in chromatin
+accessibility across sets of annotations or peaks.  @code{r-chromvar} is
+designed primarily for single-cell or sparse chromatin accessibility data like
+single cell assay for transposase-accessible chromatin using
+sequencing (@code{scATAC-seq} or sparse bulk ATAC or deoxyribonuclease
+sequence (@code{DNAse-seq}) experiments.")
+    (license license:expat)))
+
 (define-public r-singlecellexperiment
   (package
     (name "r-singlecellexperiment")