summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 86ed095b8d..e8bbc9dd10 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -710,7 +710,15 @@ interactive environment for the functional language Haskell.")
                (substitute* '("testsuite/tests/driver/T16521/all.T")
                  (("extra_files" all) (string-append "[" all))
                  (("\\]\\), " all)
-                  (string-append all "expect_broken(0)], ")))))))))
+                  (string-append all "expect_broken(0)], ")))))
+           ;; TODO: Turn this into an undconditional patch on the next rebuild.
+           ,@(if (string=? "i686-linux" (%current-system))
+              '((add-after 'skip-more-tests 'skip-failing-tests-i686
+                 (lambda _
+                   (substitute* '("testsuite/tests/codeGen/should_compile/all.T")
+                     (("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
+                      (string-append before "when(arch('i386'), skip)"))))))
+              '())))))
     (native-search-paths (list (search-path-specification
                                 (variable "GHC_PACKAGE_PATH")
                                 (files (list