summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fa8f203828..fd3e6b312b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -247,10 +247,8 @@ data types.")
     (name "python-minimal")
     (arguments
      (substitute-keyword-arguments (package-arguments python-2)
-       ((#:configure-flags _)
-        `(list "--enable-shared"
-               (string-append "LDFLAGS=-Wl,-rpath="
-                              (assoc-ref %outputs "out") "/lib")))))
+       ((#:configure-flags cf)
+        `(append ,cf '("--without-system-ffi")))))
     (inputs '())))                          ;none of the optional dependencies
 
 (define-public python-minimal
@@ -258,10 +256,8 @@ data types.")
     (name "python-minimal")
     (arguments
      (substitute-keyword-arguments (package-arguments python)
-       ((#:configure-flags _)
-        `(list "--enable-shared"
-               (string-append "LDFLAGS=-Wl,-rpath="
-                              (assoc-ref %outputs "out") "/lib")))))
+       ((#:configure-flags cf)
+        `(append ,cf '("--without-system-ffi")))))
 
     ;; OpenSSL is a mandatory dependency of Python 3.x, for urllib;
     ;; zlib is required by 'zipimport', used by pip.