summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 7e49fca263..2649326e5b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -204,6 +204,12 @@ shared NFS home directories.")
        #:configure-flags '("-Dman=true")
        #:phases
        (modify-phases %standard-phases
+         ;; Needed to pass the test phase on slower ARM and i686 machines.
+         (add-after 'unpack 'increase-test-timeout
+           (lambda _
+             (substitute* "meson.build"
+               (("(test_timeout.*) = ([[:digit:]]+)" all first second)
+                (string-append first " = " second "0")))))
          (add-after 'unpack 'disable-failing-tests
            (lambda _
              (with-directory-excursion "glib/tests"