summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tcl.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 2de2624df4..67510eb41f 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -63,6 +63,14 @@
                                       "tclsh")))))
                   %standard-phases))
 
+       ;; By default, man pages are put in PREFIX/man, but we want them in
+       ;; PREFIX/share/man.  The 'validate-documentation-location' phase is
+       ;; not able to fix this up because the default install populates both
+       ;; PREFIX/man and PREFIX/share/man.
+       #:configure-flags (list (string-append "--mandir="
+                                              (assoc-ref %outputs "out")
+                                              "/share/man"))
+
        ;; XXX: There are a few test failures (related to HTTP, most
        ;; likely related to name resolution), but that doesn't cause
        ;; `make' to fail.