summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am14
-rw-r--r--daemon.am11
-rw-r--r--doc.am4
3 files changed, 15 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index bc015e23e3..6784da014b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -420,7 +420,7 @@ include emacs.am
 
 # The self-contained tarball.
 guix-binary.%.tar.xz:
-	-GUIX_PACKAGE_PATH= \
+	$(AM_V_GEN)GUIX_PACKAGE_PATH= \
 	$(top_builddir)/pre-inst-env "$(GUILE)"			\
 	  "$(top_srcdir)/build-aux/make-binary-tarball.scm" "$*" "$@"
 
@@ -431,11 +431,11 @@ dist-hook: assert-no-store-file-names
 distcheck-hook: assert-binaries-available assert-final-inputs-self-contained
 
 sync-descriptions:
-	-GUIX_PACKAGE_PATH= \
+	$(AM_V_at)GUIX_PACKAGE_PATH= \
 	 $(top_builddir)/pre-inst-env guix lint --checkers=gnu-description
 
 gen-ChangeLog:
-	if test -d .git; then				\
+	$(AM_V_GEN)if test -d .git; then		\
 	  $(top_srcdir)/build-aux/gitlog-to-changelog	\
 	    > $(distdir)/cl-t;				\
 	  rm -f $(distdir)/ChangeLog;			\
@@ -443,7 +443,7 @@ gen-ChangeLog:
 	fi
 
 gen-AUTHORS:
-	if test -d .git; then					\
+	$(AM_V_GEN)if test -d .git; then			\
 	  rm -f "$(distdir)/AUTHORS";				\
 	  $(top_builddir)/pre-inst-env "$(GUILE)"		\
 	    "$(top_srcdir)/build-aux/generate-authors.scm"	\
@@ -452,7 +452,7 @@ gen-AUTHORS:
 
 # Make sure we're not shipping a file that embeds a local /gnu/store file name.
 assert-no-store-file-names:
-	if grep -r --exclude=*.texi --exclude=*.info				\
+	$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info			\
 	     "$(storedir)/[a-z0-9]{32}-" $(distdir) ;				\
 	then									\
 	  echo "error: store file names embedded in the distribution" >&2 ;	\
@@ -461,12 +461,12 @@ assert-no-store-file-names:
 
 # Make sure hydra.gnu.org has the important binaries.
 assert-binaries-available:
-	$(top_builddir)/pre-inst-env "$(GUILE)"				\
+	$(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)"			\
 	  "$(top_srcdir)/build-aux/check-available-binaries.scm"
 
 # Make sure the final inputs don't refer to bootstrap tools.
 assert-final-inputs-self-contained:
-	$(top_builddir)/pre-inst-env "$(GUILE)"				\
+	$(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)"			\
 	  "$(top_srcdir)/build-aux/check-final-inputs-self-contained.scm"
 
 .PHONY: sync-descriptions gen-ChangeLog gen-AUTHORS clean-go make-go
diff --git a/daemon.am b/daemon.am
index ba4be50068..3c15531f54 100644
--- a/daemon.am
+++ b/daemon.am
@@ -1,5 +1,6 @@
 # GNU Guix --- Functional package management for GNU
 # Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
 #
 # This file is part of GNU Guix.
 #
@@ -155,7 +156,7 @@ noinst_HEADERS =						\
   $(guix_daemon_headers)
 
 nix/libstore/schema.sql.hh: nix/libstore/schema.sql
-	$(GUILE) --no-auto-compile -c				\
+	$(AM_V_GEN)$(GUILE) --no-auto-compile -c		\
 	  "(use-modules (rnrs io ports))			\
 	   (call-with-output-file \"$@\"			\
 	     (lambda (out)					\
@@ -185,9 +186,9 @@ nodist_systemdservice_DATA = etc/guix-daemon.service
 
 etc/guix-daemon.service: etc/guix-daemon.service.in	\
 			 $(top_builddir)/config.status
-	$(MKDIR_P) "`dirname "$@"`"
+	$(AM_V_GEN)$(MKDIR_P) "`dirname $@`";				\
 	$(SED) -e 's|@''bindir''@|$(bindir)|' <				\
-	       "$(srcdir)/etc/guix-daemon.service.in" > "$@.tmp"
+	       "$(srcdir)/etc/guix-daemon.service.in" > "$@.tmp";	\
 	mv "$@.tmp" "$@"
 
 # The '.conf' job for Upstart.
@@ -196,9 +197,9 @@ nodist_upstartjob_DATA = etc/guix-daemon.conf
 
 etc/guix-daemon.conf: etc/guix-daemon.conf.in	\
 			 $(top_builddir)/config.status
-	$(MKDIR_P) "`dirname "$@"`"
+	$(AM_V_GEN)$(MKDIR_P) "`dirname $@`";				\
 	$(SED) -e 's|@''bindir''@|$(bindir)|' <				\
-	       "$(srcdir)/etc/guix-daemon.conf.in" > "$@.tmp"
+	       "$(srcdir)/etc/guix-daemon.conf.in" > "$@.tmp";		\
 	mv "$@.tmp" "$@"
 
 EXTRA_DIST +=					\
diff --git a/doc.am b/doc.am
index 8b8ecc7a8b..ad59aa589b 100644
--- a/doc.am
+++ b/doc.am
@@ -52,7 +52,7 @@ EXTRA_DIST           += $(OS_CONFIG_EXAMPLES_TEXI)
 MAINTAINERCLEANFILES  = $(OS_CONFIG_EXAMPLES_TEXI)
 
 doc/os-config-%.texi: gnu/system/examples/%.tmpl
-	$(MKDIR_P) "`dirname "$@"`"
+	$(AM_V_GEN)$(MKDIR_P) "`dirname $@`";	\
 	cp "$<" "$@"
 
 infoimagedir = $(infodir)/images
@@ -79,7 +79,7 @@ DOT_OPTIONS =					\
 	mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
 
 .png.eps:
-	convert "$<" "$@-tmp.eps"
+	$(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
 	mv "$@-tmp.eps" "$@"
 
 # We cannot add new dependencies to `doc/guix.pdf' & co. (info "(automake)