summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gstreamer.scm3
-rw-r--r--gnu/packages/video.scm3
2 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 099c5ffcbb..c382f04446 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -826,7 +826,8 @@ model to base your own plug-in on, here it is.")
            xorg-server-for-tests))
     (inputs
      (append
-      (if (target-x86?) (list mediasdk svt-hevc) '())
+      (if (target-x86?) (list mediasdk) '())
+      (if (target-x86-64?) (list svt-hevc) '())
       (list bluez
             bzip2
             cairo
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cc84444491..d66c42123d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -335,7 +335,8 @@ the SVT-HEVC encoder, it is possible to spread video encoding processing across
 multiple Intel's Xeon processors to achieve a real advantage of processing
 efficiency.")
     (home-page "https://01.org/svt")
-    (supported-systems '("x86_64-linux" "i686-linux"))
+    ;; Specifically targets x86_64 Intel hardware.
+    (supported-systems '("x86_64-linux"))
     (license (license:non-copyleft "file:///LICENSE.md"))))
 
 (define-public mediasdk