summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 160f926ba4..0fad3dab4e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12930,24 +12930,22 @@ recurrences of, a substring.  The package works equally in Plain TeX and LaTeX
 
 (define-public texlive-substr
   (package
-    (inherit (simple-texlive-package
-              "texlive-substr"
-              (list "doc/latex/substr/"
-                    "tex/latex/substr/")
-              (base32
-               "0kfd4kq5yrg65f2mpric1cs1xr416wgj9bdixpibgjsdg5fb73sw")
-              #:trivial? #t))
-    (home-page "https://www.ctan.org/pkg/substr")
+    (name "texlive-substr")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/substr/" "tex/latex/substr/")
+             (base32
+              "0kfd4kq5yrg65f2mpric1cs1xr416wgj9bdixpibgjsdg5fb73sw")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/substr")
     (synopsis "Deal with substrings in strings")
     (description
-     "The package provides commands to deal with substrings of strings.  Macros
-are provided to:
-
-@itemize
-@item determine if one string is a substring of another,
-@item return the parts of a string before or after a substring, and
-@item count the number of occurrences of a substring.
-@end itemize")
+     "The package provides commands to deal with substrings of strings.
+Macros are provided to determine if one string is a substring of another,
+return the parts of a string before or after a substring, and count the number
+of occurrences of a substring.")
     (license license:lppl1.0+)))
 
 (define-public texlive-totcount