summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bdw-gc.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index b788c3288e..5ff4649716 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -64,12 +64,17 @@
                                  (%current-target-system)))
                #~("--disable-gcj-support")
                #~())))
-     (if (target-ppc64le?)
-       (list #:make-flags
-             ;; This is a known workaround upstream.
-             ;; https://github.com/ivmai/bdwgc/issues/479
-             #~(list "CFLAGS_EXTRA=-DNO_SOFT_VDB"))
-       '())))
+     (cond
+       ((target-ppc64le?)
+        (list #:make-flags
+              ;; This is a known workaround upstream.
+              ;; https://github.com/ivmai/bdwgc/issues/479
+              #~(list "CFLAGS_EXTRA=-DNO_SOFT_VDB")))
+       ((target-ppc32?)
+        (list #:make-flags
+              ;; Similar to above.
+              #~(list "CFLAGS_EXTRA=-DNO_MPROTECT_VDB")))
+       (else '()))))
    (native-inputs (list pkg-config))
    (propagated-inputs
     (if (%current-target-system)