summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb2519bcda..ed7d9b5032 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,7 +35,8 @@
 ;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
 ;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2022 Navid Afkhami  <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33459,3 +33460,22 @@ interface.")
 purposes, illustrating/testing meta-analytic methods, and validating published
 analyses.")
     (license license:gpl2+)))
+
+(define-public r-mathjaxr
+  (package
+    (name "r-mathjaxr")
+    (version "1.6-0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "mathjaxr" version))
+              (sha256
+               (base32
+                "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))))
+    (properties `((upstream-name . "mathjaxr")))
+    (build-system r-build-system)
+    (home-page "https://github.com/wviechtb/mathjaxr")
+    (synopsis "Using 'Mathjax' in Rd Files")
+    (description
+     "This package provides 'MathJax' and macros to enable its use within Rd files for
+rendering equations in the HTML help files.")
+    (license (list license:asl2.0 license:gpl3))))