summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/simulation.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 4a216d00db..f78237a3c8 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -310,11 +310,7 @@ the complexity of that interface.  Parallel support depends on the
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             (setenv "PYTHONPATH"
-                     (string-append (getcwd) ":" (getenv "PYTHONPATH")))
-             (with-directory-excursion "test"
-               (invoke "py.test"))
-             #t)))))
+             (invoke "py.test" "test"))))))
     (home-page "https://bitbucket.org/fenics-project/ufl/")
     (synopsis "Unified language for form-compilers")
     (description "The Unified Form Language (UFL) is a domain specific