summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 51b40c889e..774194d87b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -201,7 +201,16 @@ client and server, a telnet client and server, and an rsh client and server.")
                       (delete-file (string-append bin "/groups"))
                       (for-each delete-file (find-files man "^groups\\."))
                       #t))
-                  %standard-phases))))
+                  (alist-cons-after
+                   'unpack 'reset-timestamps
+                   (lambda _
+                     ;; FIXME: Reset the file timestamps here, until the
+                     ;; 'unpack' phase does it for us.  See
+                     ;; <https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00098.html>.
+                     (for-each (lambda (file)
+                                 (utime file 0 0 0))
+                               (find-files "." "")))
+                   %standard-phases)))))
 
     (inputs (if (string-suffix? "-linux"
                                 (or (%current-target-system)