summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6d89104226..8dd076eb65 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16762,6 +16762,51 @@ query them from the comfort of your editor.")
     (home-page "https://github.com/hrs/engine-mode")
     (license license:gpl3+)))
 
+(define-public emacs-engrave-faces
+  (package
+    (name "emacs-engrave-faces")
+    (version "0.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/engrave-faces-"
+                                  version ".tar"))
+              (sha256
+               (base32
+                "1q4sjl2rvcfwcirm32nmi53258ln71yhh1dgszlxwknm38a14v3i"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/tecosaur/engrave-faces")
+    (synopsis "Convert font-lock faces to other formats")
+    (description "There are some great packages for exporting buffers to
+particular formats, but each one seems to reinvent the core mechanism of
+processing the font-lock in a buffer such that it can be exported to
+a particular format.
+
+This package aims to produce a versatile generic core which can process
+a fontified buffer and pass the data to any number of backends which can deal
+with specific output formats.")
+    (license license:gpl3+)))
+
+(define-public emacs-inheritenv
+  (package
+    (name "emacs-inheritenv")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/purcell/inheritenv")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ygzf70vfb7qwpsllcq5i3brprsnx3sxy2zng02mzwrr5jkx4ypc"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/purcell/inheritenv/releases")
+    (synopsis "Emacs temp buffers inherit buffer-local environment variables")
+    (description
+     "Inheritenv provides tools to execute processes inheriting the calling
+buffer's environment.")
+    (license license:gpl3+)))
+
 (define-public emacs-inheritenv
   (package
     (name "emacs-inheritenv")