summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/bioinformatics.scm6
-rw-r--r--gnu/packages/patches/bowtie-fix-makefile.patch31
3 files changed, 36 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 6c2d66bbda..1211855f54 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -346,6 +346,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/automake-skip-amhello-tests.patch	\
   gnu/packages/patches/avahi-localstatedir.patch		\
   gnu/packages/patches/avrdude-fix-libusb.patch			\
+  gnu/packages/patches/bowtie-fix-makefile.patch		\
   gnu/packages/patches/bigloo-gc-shebangs.patch			\
   gnu/packages/patches/binutils-ld-new-dtags.patch		\
   gnu/packages/patches/binutils-loongson-workaround.patch	\
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ff6c3379af..620c8090b7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -95,7 +95,8 @@ BED, GFF/GTF, VCF.")
                   (("^CPP = .*$") "CPP = g++")
                   ;; replace BUILD_HOST and BUILD_TIME for deterministic build
                   (("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
-                  (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
+                  (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))
+              (patches (list (search-patch "bowtie-fix-makefile.patch")))))
     (build-system gnu-build-system)
     (inputs `(("perl" ,perl)
               ("perl-clone" ,perl-clone)
@@ -133,6 +134,7 @@ aligning to relatively long (e.g. mammalian) genomes.  Bowtie 2 indexes the
 genome with an FM Index to keep its memory footprint small: for the human
 genome, its memory footprint is typically around 3.2 GB.  Bowtie 2 supports
 gapped, local, and paired-end alignment modes.")
+    (supported-systems '("x86_64-linux"))
     (license license:gpl3+)))
 
 (define-public samtools
diff --git a/gnu/packages/patches/bowtie-fix-makefile.patch b/gnu/packages/patches/bowtie-fix-makefile.patch
new file mode 100644
index 0000000000..5ac65731cb
--- /dev/null
+++ b/gnu/packages/patches/bowtie-fix-makefile.patch
@@ -0,0 +1,31 @@
+From 4a99b0023bdfbbe486b9649489a32ea184c18c9a Mon Sep 17 00:00:00 2001
+From: Valentin Antonescu <valentin@jhu.edu>
+Date: Tue, 2 Dec 2014 11:19:13 -0500
+Subject: [PATCH] Make sure the Mavericks test happens only under Darwin.
+
+---
+ Makefile | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d74f7c8..a4cdfa7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -54,12 +54,11 @@ endif
+ MACOS = 0
+ ifneq (,$(findstring Darwin,$(shell uname)))
+ 	MACOS = 1
+-endif
+-
+-ifneq (,$(findstring 13,$(shell uname -r)))
+-	CPP = clang++
+-	CC = clang
+-	EXTRA_FLAGS += -stdlib=libstdc++
++	ifneq (,$(findstring 13,$(shell uname -r)))
++		CPP = clang++
++		CC = clang
++		EXTRA_FLAGS += -stdlib=libstdc++
++	endif
+ endif
+ 
+ POPCNT_CAPABILITY ?= 1