summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/music.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index bde01cb312..a14719f89a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4730,7 +4730,7 @@ standalone JACK client and an LV2 plugin is also available.")
 (define-public sfizz
   (package
     (name "sfizz")
-    (version "1.0.0")
+    (version "1.2.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/sfztools/sfizz"
@@ -4738,16 +4738,15 @@ standalone JACK client and an LV2 plugin is also available.")
                                   "/sfizz-" version ".tar.gz"))
               (sha256
                (base32
-                "1pk67xvyqkvhjz2q5hbj5v0mnfvdvvl8vl5bsh6ymwiq3glkd41l"))
+                "1wsr3dpn7a7whqn480m02kp6n4raamnfi3imhf2q8k58md1yn9jw"))
               (modules '((guix build utils)))
               (snippet
-               ;; TODO: pugixml is bundled, but can only be removed in
-               ;; versions after 1.0.0.
                '(for-each delete-file-recursively
                           '("external/abseil-cpp"
                             "external/simde"
                             "plugins/editor/external/vstgui4"
-                            "plugins/vst")))))
+                            "plugins/vst"
+                            "src/external/pugixml")))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
@@ -4755,7 +4754,11 @@ standalone JACK client and an LV2 plugin is also available.")
              "-DSFIZZ_VST=OFF"
              "-DSFIZZ_VST2=OFF"
              "-DSFIZZ_TESTS=ON"
-             "-DSFIZZ_USE_SYSTEM_ABSEIL=ON")))
+             "-DSFIZZ_USE_SYSTEM_ABSEIL=ON"
+             "-DSFIZZ_USE_SYSTEM_PUGIXML=ON"
+             ;; XXX: Guix SIMDe version 0.7.2 is not enough.
+             ;; "-DSFIZZ_USE_SYSTEM_SIMDE=ON"
+             )))
     (native-inputs
      (list pkg-config))
     (inputs