summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gl.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 2f7c25bc57..b53b42a9ba 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -408,15 +408,11 @@ svga,swrast,virgl")))
                                    ;; This is probably a big-endian test failure.
                                    "src/gallium/targets/osmesa/meson.build")
                       (("if with_tests") "if not with_tests"))
-                    (substitute* "src/util/tests/format/meson.build"
-                      ;; This is definately an endian-ness test failure.
-                      (("'u_format_test', ") ""))
-                    ;; It is only this portion of the test which fails.
-                    (substitute* "src/mesa/main/tests/meson.build"
-                      ((".*mesa_formats.*") ""))
                     ;; This test times out and receives SIGTERM.
                     (substitute* "src/amd/common/meson.build"
-                      (("and not with_platform_windows") "and with_platform_windows"))))
+                      (("and not with_platform_windows") "and with_platform_windows"))
+                    (substitute* "src/compiler/nir/meson.build"
+                      ((".*loop_unroll_tests.*") ""))))
                  ("i686-linux"
                   ;; This test is known to fail on i686 (see:
                   ;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091).