summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c9659c6cd0..30c27cff6d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1422,3 +1422,28 @@ and density estimation")
      "This package provides a violin plot, which is a combination of a box
 plot and a kernel density plot.")
     (license license:bsd-3)))
+
+(define-public r-rsofia
+  (package
+    (name "r-rsofia")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              ;; This package has been removed from CRAN, so we can
+              ;; only fetch it from the archives.
+              (uri (string-append "https://cran.r-project.org/src/"
+                                  "contrib/Archive/RSofia/RSofia_"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0q931y9rcf6slb0s2lsxhgqrzy4yqwh8hb1124nxg0bjbxvjbihn"))))
+    (properties `((upstream-name . "RSofia")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/src/contrib/Archive/RSofia")
+    (synopsis "Port of sofia-ml to R")
+    (description "This package is a port of sofia-ml to R.  Sofia-ml is a
+suite of fast incremental algorithms for machine learning that can be used for
+training models for classification or ranking.")
+    (license license:asl2.0)))