summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/webkit.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 5ab93ad9eb..f47fff25d2 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -199,6 +199,13 @@ engine that uses Wayland for graphics output.")
                 (substitute* "Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp"
                   (("libWPEBackend-fdo-[\\.0-9]+\\.so" all)
                    (search-input-file inputs (string-append "lib/" all)))))))
+          #$@(if (target-x86-32?)
+                 ;; Don't include x86intrin.h on i686-linux.
+                 '((add-after 'unpack 'fix-headers
+                     (lambda _
+                       (substitute* "Source/ThirdParty/ANGLE/src/common/platform.h"
+                         (("\\|\\| defined\\(__i386__\\)") "")))))
+                 '())
           #$@(if (target-x86-64?)
                  '()
                  '((add-after 'unpack 'disable-sse2