summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/astronomy.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 22d6db984b..b69ba4d96a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2611,12 +2611,7 @@ of axis order, spatial projections, and spectral units that exist in the wild.
       #~(modify-phases %standard-phases
           (add-after 'unpack 'preparations
             (lambda _
-              ;; Fixing: setuptools-scm was unable to detect version for ...
-              (substitute* "setup.py"
-                (("use_scm_version=True")
-                 (format #f "version=~s" #$version))
-                (("setup_requires=\\['setuptools_scm'\\],.*")
-                 ""))
+              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
               ;; Use our own libraries in place of bundles.
               (setenv "USE_SYSTEM_QD" "1"))))))
     (native-inputs