summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c713d9a3f6..c16a1cf6e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -489,11 +489,13 @@ AM_DISTCHECK_CONFIGURE_FLAGS =			\
   --with-nix-prefix="$(NIX_PREFIX)"		\
   --enable-daemon
 
-# The self-contained tarball.
+# The self-contained tarball.  Add 'glibc-utf8-locales' along with glibc just
+# so 'etc/profile' defines 'GUIX_LOCPATH' pointing to a valid set of locales.
 guix-binary.%.tar.xz:
 	$(AM_V_GEN)GUIX_PACKAGE_PATH=				\
 	tarball=`$(top_builddir)/pre-inst-env guix pack -C xz	\
-	  -s "$*" --localstatedir guix` ;			\
+	  -s "$*" --localstatedir guix glibc-utf8-locales	\
+	  -e  '(@@ (gnu packages commencement) glibc-final)'` ;	\
 	cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"