summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 69b4af013a..538fad32a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -412,6 +412,18 @@ AM_DISTCHECK_CONFIGURE_FLAGS =			\
   --with-nix-prefix="$(NIX_PREFIX)"		\
   --enable-daemon
 
-dist-hook:
+dist-hook: sync-synopses gen-ChangeLog
+
+sync-synopses:
 	-$(top_builddir)/pre-inst-env $(GUILE)		\
 	   $(top_srcdir)/build-aux/sync-synopses.scm
+
+gen-ChangeLog:
+	if test -d .git; then				\
+	  $(top_srcdir)/build-aux/gitlog-to-changelog	\
+	    > $(distdir)/cl-t;				\
+	  rm -f $(distdir)/ChangeLog;			\
+	  mv $(distdir)/cl-t $(distdir)/ChangeLog;	\
+	fi
+
+.PHONY: sync-synopses gen-ChangeLog