summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1be09d7637..4dfcd06d0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@
 # Copyright © 2016, 2017 Mark H Weaver <mhw@netris.org>
 # Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 # Copyright © 2017 Leo Famulari <leo@famulari.name>
+# Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 #
 # This file is part of GNU Guix.
 #
@@ -87,6 +88,7 @@ MODULES =					\
   guix/build-system/waf.scm			\
   guix/build-system/r.scm			\
   guix/build-system/ruby.scm			\
+  guix/build-system/texlive.scm			\
   guix/build-system/trivial.scm			\
   guix/ftp-client.scm				\
   guix/http-client.scm				\
@@ -114,6 +116,7 @@ MODULES =					\
   guix/build/ocaml-build-system.scm		\
   guix/build/r-build-system.scm			\
   guix/build/ruby-build-system.scm		\
+  guix/build/texlive-build-system.scm		\
   guix/build/waf-build-system.scm		\
   guix/build/haskell-build-system.scm		\
   guix/build/store-copy.scm			\
@@ -142,6 +145,7 @@ MODULES =					\
   guix/import/cran.scm				\
   guix/import/hackage.scm			\
   guix/import/elpa.scm   			\
+  guix/import/texlive.scm   			\
   guix/scripts.scm				\
   guix/scripts/download.scm			\
   guix/scripts/perform-download.scm		\
@@ -164,6 +168,7 @@ MODULES =					\
   guix/scripts/import/nix.scm			\
   guix/scripts/import/hackage.scm		\
   guix/scripts/import/elpa.scm  		\
+  guix/scripts/import/texlive.scm  		\
   guix/scripts/environment.scm			\
   guix/scripts/publish.scm			\
   guix/scripts/edit.scm				\
@@ -300,6 +305,7 @@ SCM_TESTS =					\
   tests/hackage.scm				\
   tests/cran.scm				\
   tests/elpa.scm				\
+  tests/texlive.scm				\
   tests/store.scm				\
   tests/monads.scm				\
   tests/gexp.scm				\