summary refs log tree commit diff
path: root/etc
diff options
context:
space:
mode:
Diffstat (limited to 'etc')
-rwxr-xr-xetc/guix-install.sh17
-rw-r--r--etc/news.scm76
-rw-r--r--etc/release-manifest.scm1
-rw-r--r--etc/teams.scm.in32
4 files changed, 115 insertions, 11 deletions
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index ea10f35250..bbb4219965 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -11,6 +11,7 @@
 # Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
 # Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 # Copyright © 2022 Prafulla Giri <prafulla.giri@protonmail.com>
+# Copyright © 2023 Andrew Tropin <andrew@trop.in>
 #
 # This file is part of GNU Guix.
 #
@@ -549,15 +550,19 @@ export PATH="$_GUIX_PROFILE/bin${PATH:+:}$PATH"
 # searches 'Info-default-directory-list'.
 export INFOPATH="$_GUIX_PROFILE/share/info:$INFOPATH"
 
-# GUIX_PROFILE: User's default profile
-# Prefer the one from 'guix home' if it exists.
+# GUIX_PROFILE: User's default profile and home profile
+GUIX_PROFILE="$HOME/.guix-profile"
+[ -f "$GUIX_PROFILE/etc/profile" ] && . "$GUIX_PROFILE/etc/profile"
+[ -L "$GUIX_PROFILE" ] || \
+GUIX_LOCPATH="$GUIX_PROFILE/lib/locale:${GUIX_LOCPATH:+:}$GUIX_LOCPATH"
+
 GUIX_PROFILE="$HOME/.guix-home/profile"
-[ -L $GUIX_PROFILE ] || GUIX_PROFILE="$HOME/.guix-profile"
-[ -L $GUIX_PROFILE ] || return
-GUIX_LOCPATH="$GUIX_PROFILE/lib/locale"
+[ -f "$GUIX_PROFILE/etc/profile" ] && . "$GUIX_PROFILE/etc/profile"
+[ -L "$GUIX_PROFILE" ] || \
+GUIX_LOCPATH="$GUIX_PROFILE/lib/locale:${GUIX_LOCPATH:+:}$GUIX_LOCPATH"
+
 export GUIX_LOCPATH
 
-[ -f "$GUIX_PROFILE/etc/profile" ] && . "$GUIX_PROFILE/etc/profile"
 EOF
 }
 
diff --git a/etc/news.scm b/etc/news.scm
index 55d1218df5..7f38f8f294 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -16,7 +16,7 @@
 ;; Copyright © 2021, 2022 Maxime Devos <maximedevos@telenet.be>
 ;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
-;; Copyright © 2021 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;; Copyright © 2021, 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
 ;;
 ;; Copying and distribution of this file, with or without modification, are
@@ -26,6 +26,80 @@
 (channel-news
  (version 0)
 
+ (entry (commit "21564fada141bfba25d471518b293b6004244c3a")
+        (title
+         (en "Linux-libre LTS kernel updated to 6.1")
+         (de "Linux-libre LTS Kernel wird auf 6.1 aktualisiert"))
+        (body
+         (en "The default version of the @code{linux-libre-lts} kernel has been
+             updated to the 6.1 longterm release series.")
+         (de "Der standardmäßig verwendete @code{linux-libre-lts}-Kernel basiert
+              jetzt auf der 6.1-Versionsreihe (Langzeitunterstützung).")))
+
+ (entry (commit "57db09aae73e3713a10c5253758d84e1046f80dc")
+        (title
+         (en "Using Guix within @command{guix shell --container}")
+         (de "Guix innerhalb @command{guix shell --container} nutzen")
+         (fr "Utilisation de Guix dans @command{guix shell --container}"))
+        (body
+         (en "The @option{--container} (or @option{-C}) option lets you spawn
+a container---an isolated software environment.  In some cases, it is useful
+to use Guix from within the container, something that is normally not
+possible.
+
+The new @option{--nesting} (or @option{-W}) option lets you do exactly that: a
+container created with that option will let you use @command{guix} commands,
+including @command{guix shell -C}, @emph{inside} of it.
+
+The example below shows how to evaluate a @file{guix.scm} file to build a
+package from within an isolated container, which is useful if @file{guix.scm}
+is untrusted:
+
+@example
+guix shell -CW -- guix build -f guix.scm
+@end example
+
+Run @command{info \"(guix) Invoking guix shell\"} for more information.")
+         (de "Mit der Befehlszeilenoption @option{--container} (oder
+@option{-C}) können Sie Container anlegen, also isolierte
+Software-Umgebungen.  Allerdings will man manchmal Guix innerhalb eines
+Containers nutzen, was unmöglich ist, wenn Sie es normal aufrufen.
+
+Die neue Befehlszeilenoption @option{--nesting} (oder @option{-W}) ergänzt
+genau das: In einem damit angelegten Container lassen sich
+@command{guix}-Befehle, einschließlich @command{guix shell -C}, @emph{im
+Container} benutzen.
+
+Folgendes Beispiel zeigt, wie Sie eine Datei @file{guix.scm} auswerten lassen,
+um ein Paket aus dem isolierten Container heraus erstellen zu lassen. Das
+können Sie gebrauchen, wenn Sie @file{guix.scm} @emph{nicht} vertrauen:
+
+@example
+guix shell -CW -- guix build -f guix.scm
+@end example
+
+Führen Sie @command{info \"(guix.de) Aufruf von guix shell\"} aus, um mehr
+zu erfahren.")
+         (fr "L'option @option{--container} (ou @option{-C}) permet de
+démarrer un conteneur---un environnement logiciel isolé.  Dans certains cas,
+il peut être utile d'utiliser Guix à l'intérieur du conteneur, ce qui n'est
+normalement pas possible.
+
+La nouvelle option @option{--nesting} (ou @option{-W}) résoud ce problème : un
+conteneur créé avec cette option permet d'utiliser des commandes
+@command{guix} à l'intérieur, y compris @command{guix shell -C}.
+
+L'exemple ci-dessous montre comment évaluer un fichier @file{guix.scm} pour
+construire un paquet depuis un conteneur isolé, ce qui est utile si
+@file{guix.scm} n'est pas de confiance :
+
+@example
+guix shell -CW -- guix build -f guix.scm
+@end example
+
+Lancer @command{info \"(guix.fr) Invoquer guix shell\"} pour plus
+d'informations.")))
+
  (entry (commit "0e18c5e5bcb9204c278cfc75493d3b02b746d5c3")
         (title
          (en "Linux-libre kernel updated to 6.2")
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index be63db3d3c..773910ac80 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020-2022 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index e582993450..37a3c8e191 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -436,6 +436,21 @@ importer."
         "Reproducible Builds tooling and issues that affect any guix packages."
         #:scope (list "gnu/packages/diffoscope.scm")))
 
+(define-team gnome
+  (team 'gnome
+        #:name "Gnome team"
+        #:description
+        "The Gnome desktop environment, along with core technologies such as
+GLib/GIO, GTK, GStreamer and Webkit."
+        #:scope (list "gnu/packages/glib.scm"
+                      "gnu/packages/gstreamer.scm"
+                      "gnu/packages/gtk.scm"
+                      "gnu/packages/gnome.scm"
+                      "gnu/packages/gnome-xyz.scm"
+                      "gnu/packages/webkit.scm"
+                      "guix/build/glib-or-gtk-build-system.scm"
+                      "guix/build/meson-build-system.scm")))
+
 (define-team xfce
   (team 'xfce
         #:name "Xfce team"
@@ -446,7 +461,8 @@ importer."
   (team 'lxqt
         #:name "LXQt team"
         #:description "LXQt desktop environment."
-        #:scope (list "gnu/packages/lxqt.scm")))
+        #:scope (list "gnu/packages/lxqt.scm"
+                      "gnu/packages/qt.scm")))
 
 
 (define-member (person "Eric Bavier"
@@ -467,7 +483,7 @@ importer."
 
 (define-member (person "Andreas Enge"
                        "andreas@enge.fr")
-  science)
+  lxqt science)
 
 (define-member (person "Tobias Geerinckx-Rice"
                        "me@tobias.gr")
@@ -511,7 +527,7 @@ importer."
 
 (define-member (person "Liliana Marie Prikler"
                        "liliana.prikler@gmail.com")
-  emacs games)
+  emacs games gnome)
 
 (define-member (person "Ricardo Wurmus"
                        "rekado@elephly.net")
@@ -543,7 +559,7 @@ importer."
 
 (define-member (person "Raghav Gururajan"
                        "rg@raghavgururajan.name")
-  mentors)
+  gnome mentors)
 
 (define-member (person "宋文武"
                        "iyzsong@envs.net")
@@ -553,6 +569,14 @@ importer."
                        "vagrant@reproducible-builds.org")
   reproduciblebuilds)
 
+(define-member (person "Zhu Zihao"
+                       "all_but_last@163.com")
+  localization xfce)
+
+(define-member (person "Maxim Cournoyer"
+                       "maxim.cournoyer@gmail.com")
+  gnome)
+
 
 (define (find-team name)
   (or (hash-ref %teams (string->symbol name))