summary refs log tree commit diff
path: root/gnu/packages.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages.scm')
-rw-r--r--gnu/packages.scm21
1 files changed, 2 insertions, 19 deletions
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 44a56dfde0..97e6cb347f 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -110,25 +110,8 @@ for system '~a'")
                         file-name system)))))))
 
 (define %distro-root-directory
-  ;; Absolute file name of the module hierarchy.  Since (gnu packages …) might
-  ;; live in a directory different from (guix), try to get the best match.
-  (letrec-syntax ((dirname* (syntax-rules ()
-                              ((_ file)
-                               (dirname file))
-                              ((_ file head tail ...)
-                               (dirname (dirname* file tail ...)))))
-                  (try      (syntax-rules ()
-                              ((_ (file things ...) rest ...)
-                               (match (search-path %load-path file)
-                                 (#f
-                                  (try rest ...))
-                                 (absolute
-                                  (dirname* absolute things ...))))
-                              ((_)
-                               #f))))
-    (try ("gnu/packages/base.scm" gnu/ packages/)
-         ("gnu/packages.scm"      gnu/)
-         ("guix.scm"))))
+  ;; Absolute file name of the module hierarchy.
+  (dirname (search-path %load-path "guix.scm")))
 
 (define %package-module-path
   ;; Search path for package modules.  Each item must be either a directory