summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f6ff32c8a2..a5b84af61a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -794,50 +794,6 @@ status for the CPU sockets, expansion slots (e.g. AGP, PCI, ISA) and memory
 module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
     (license gpl2+)))
 
-(define-public flashrom
-  (package
-    (name "flashrom")
-    (version "0.9.7")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://download.flashrom.org/releases/flashrom-"
-                    version ".tar.bz2"))
-              (sha256
-               (base32
-                "1s9pc4yls2s1gcg2ar4q75nym2z5v6lxq36bl6lq26br00nj2mas"))
-              (patches (list (search-patch "flashrom-use-libftdi1.patch")))))
-    (build-system gnu-build-system)
-    (inputs `(("dmidecode" ,dmidecode)
-              ("pciutils" ,pciutils)
-              ("libusb" ,libusb)
-              ("libftdi" ,libftdi)))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (arguments
-     '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
-       #:tests? #f   ; no 'check' target
-       #:phases
-       (alist-delete
-        'configure
-        (alist-cons-before
-         'build 'patch-exec-paths
-         (lambda* (#:key inputs #:allow-other-keys)
-           (substitute* "dmi.c"
-             (("\"dmidecode\"")
-              (format #f "~S"
-                      (string-append (assoc-ref inputs "dmidecode")
-                                     "/sbin/dmidecode")))))
-         %standard-phases))))
-    (home-page "http://flashrom.org/")
-    (synopsis "Identify, read, write, erase, and verify ROM/flash chips")
-    (description
-     "flashrom is a utility for identifying, reading, writing,
-verifying and erasing flash chips.  It is designed to flash
-BIOS/EFI/coreboot/firmware/optionROM images on mainboards,
-network/graphics/storage controller cards, and various other
-programmer devices.")
-    (license gpl2)))
-
 (define-public acpica
   (package
     (name "acpica")