summary refs log tree commit diff
path: root/gnu/packages/aidc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aidc.scm')
-rw-r--r--gnu/packages/aidc.scm122
1 files changed, 70 insertions, 52 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 3db631d92e..ac85dca4b0 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -30,60 +30,66 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages video)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu))
 
 (define-public zxing-cpp
-  (package
+  ;; Use the master branch as it includes unreleased build system improvements
+  ;; allowing to use system libraries (instead of attempting to fetch them
+  ;; from the Internet).
+  (let ((revision "0")
+        (commit "00783db7aa3bcf8620a301854ac71c0ceaaca0c1"))
+    (package
+      (name "zxing-cpp")
+      (version (git-version "1.2.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/nu-book/zxing-cpp")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1yl2cpaqiv1g4nq9v0xfj1vd5faz55k4541vz6hsffvcxgn9nmc5"))))
+      (build-system cmake-build-system)
+      (native-inputs
+       `(("fmt" ,fmt)
+         ("googletest" ,googletest)))
+      (synopsis "C++ port of ZXing")
+      (description "ZXing-CPP is a barcode scanning library.")
+      (home-page "https://github.com/nu-book/zxing-cpp")
+      (license license:asl2.0))))
+
+;;; This older variant is kept for gst-plugins-bad (see:
+;;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1684).
+(define-public zxing-cpp-1.2
+  (package/inherit zxing-cpp
     (name "zxing-cpp")
-    (version "1.0.8")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/nu-book/zxing-cpp")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "011sq8wcjfxbnd8sj6bf2fgkamlp8gj6q835g61c952npvwsnl71"))))
-    (native-inputs
-     `(("googletest-source" ,(package-source googletest))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:out-of-source? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unpack-googletest
-           ;; Copy the googletest sources to where the CMake build expects them.
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((source (assoc-ref inputs "googletest-source"))
-                   (target "test/unit/googletest-src"))
-               (mkdir-p target)
-               (copy-recursively source target)
-               ;; Disable downloading via ExternalProject.
-               (substitute* "test/unit/CMakeLists.txt.in"
-                (("ExternalProject_Add\\(") "message("))
-               #t)))
-         (replace 'check
-           (lambda _
-             (with-directory-excursion "test/unit"
-               (invoke "cmake" ".")
-               (invoke "make")
-               (invoke "./ZXingUnitTest"))
-             #t)))))
-    (synopsis "C++ port of ZXing")
-    (description "ZXing-CPP is a barcode scanning library.")
-    (home-page "https://github.com/nu-book/zxing-cpp")
-    (license license:asl2.0)))
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nu-book/zxing-cpp")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gjj9c7h634rrmmgzbc7cxjqsxdq0paj6113k02ncjm1s9abk7ik"))))
+    ;; Disable tests to avoid bundled dependencies.
+    (arguments '(#:tests? #f
+                 #:configure-flags '("-DBUILD_BLACKBOX_TESTS=OFF")))
+    (native-inputs '())))
 
 (define-public barcode
   (package
@@ -169,16 +175,18 @@ C/C++ programs to use its capabilities without restrictions or overhead.")
 (define-public zbar
   (package
     (name "zbar")
-    (version "0.23")
+    (version "0.23.90")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://linuxtv.org/downloads/zbar/zbar-"
-                           version
-                           ".tar.bz2"))
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/mchehab/zbar")
+         (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0bmd93a15qpgbsq9c9j33qms18rdrgz6gbc48zi6z9w5pvrvi7z9"))))
+         "0rf3i7lx0fqzxsngird6l4d4dnl612nr32rm8sib699qqx67px8n"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags (list "--with-gtk=auto"
@@ -187,17 +195,27 @@ C/C++ programs to use its capabilities without restrictions or overhead.")
                                               (assoc-ref %outputs "out")
                                               "/etc"))))
     (native-inputs
-     `(("glib" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("gettext" ,gettext-minimal)
+       ("glib" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)
+       ("python-wrapper" ,python-wrapper)))
     (inputs
-     `(("gobject-introspection" ,gobject-introspection)
-       ("gtk+" ,gtk+)
+     `(("dbus" ,dbus)
        ("imagemagick" ,imagemagick)
        ("libjpeg" ,libjpeg-turbo)
+       ("perl" ,perl)
        ("python" ,python)
-       ("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)
        ("v4l-utils" ,v4l-utils)))
+    (propagated-inputs
+     ;; These are in 'requires' field of .pc files.
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("qtbase" ,qtbase-5)))
     (synopsis "Bar code reader")
     (description
      "ZBar can read barcodes from various sources, such as video streams,