summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 71a4b3dc9b..f94aba1ebf 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1427,7 +1427,9 @@ objects.")
                (replace 'install
                  (lambda _ (invoke "./remake" "-s" "-d" "install")))
                (replace 'check
-                 (lambda _ (invoke "./remake" "check"))))))
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "./remake" "check")))))))
     (native-inputs (list autoconf automake bison flex libtool))
     (inputs (list boost gmp mpfr))
     (home-page "https://gitlab.inria.fr/gappa/gappa")