summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index c889433b41..a58ad84488 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -740,11 +740,11 @@ Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
 			(setenv "EIGEN_SEED" "1") ;for reproducibility
                         ;; First build the tests, in parallel.  See
                         ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
-                        (and (zero? (system* "make" "buildtests" dash-j))
+                        (invoke "make" "buildtests" dash-j)
 
-                             ;; Then run 'CTest' with -V so we get more
-                             ;; details upon failure.
-                             (zero? (system* "ctest" "-V" dash-j)))))))))
+                        ;; Then run 'CTest' with -V so we get more
+                        ;; details upon failure.
+                        (invoke "ctest" "-V" dash-j)))))))
     (home-page "https://eigen.tuxfamily.org")
     (synopsis "C++ template library for linear algebra")
     (description