summary refs log tree commit diff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index ba8ce00fbd..b8524681fa 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -323,7 +323,7 @@ audio or video backends, ensuring good performance.")
 (define-public lightspark
   (package
     (name "lightspark")
-    (version "0.8.5")
+    (version "0.8.6")
     (source
      (origin
        (method git-fetch)
@@ -332,7 +332,7 @@ audio or video backends, ensuring good performance.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "00535ndzjbz5xyr95cih01wlkc2mgvg60bv6amz4lnnglk0c5v0p"))))
+        (base32 "0v7d7vwb0xqkk3v8dyks0wyk52ga57v5lg93y74v1d2wh7spmmzw"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ;requires Adobe Flex SDK, see README.tests
@@ -352,29 +352,28 @@ audio or video backends, ensuring good performance.")
              (when tests?
                (invoke "./tests")))))))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")
-       ("nasm" ,nasm)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)))
+     (list gettext-minimal
+           `(,glib "bin")
+           nasm
+           perl
+           pkg-config
+           python-wrapper))
     (inputs
-     `(("cairo" ,cairo)
-       ("curl" ,curl)
-       ("ffmpeg" ,ffmpeg)
-       ("freeglut" ,freeglut)
-       ("glew" ,glew)
-       ("glibmm" ,glibmm)
-       ("gnash" ,gnash)
-       ("gnutls" ,gnutls)
-       ("libjpeg" ,libjpeg-turbo)
-       ("openssl" ,openssl)
-       ("pango" ,pango)
-       ("pcre2" ,pcre2)
-       ("rtmpdump" ,rtmpdump)
-       ("sdl2" ,sdl2)
-       ("sdl2-mixer" ,sdl2-mixer)
-       ("zlib" ,zlib)))
+     (list cairo
+           curl
+           ffmpeg
+           freeglut
+           glew
+           glibmm
+           gnutls
+           libjpeg-turbo
+           openssl
+           pango
+           pcre2
+           rtmpdump
+           sdl2
+           sdl2-mixer
+           zlib))
     (home-page "https://lightspark.github.io/")
     (synopsis "Flash player implementation")
     (description