summary refs log tree commit diff
path: root/gnu/packages/apl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/apl.scm')
-rw-r--r--gnu/packages/apl.scm75
1 files changed, 47 insertions, 28 deletions
diff --git a/gnu/packages/apl.scm b/gnu/packages/apl.scm
index badec04333..e483876cc5 100644
--- a/gnu/packages/apl.scm
+++ b/gnu/packages/apl.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,9 +20,11 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages apl)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix git-download)
+  #:use-module (guix svn-download)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
-  #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages maths)
@@ -30,30 +33,46 @@
   #:use-module (gnu packages sqlite))
 
 (define-public apl
-  (package
-    (name "apl")
-    (version "1.8")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
-      (sha256
-       (base32
-        "1jxvv2h3y1am1fw6r5sn3say1n0dj8shmscbybl0qhqdia2lqkql"))))
-    (build-system gnu-build-system)
-    (home-page "https://www.gnu.org/software/apl/")
-    (inputs
-     `(("gettext" ,gettext-minimal)
-       ("lapack" ,lapack)
-       ("pcre" ,pcre2)
-       ("sqlite" ,sqlite)
-       ("readline" ,readline)))
-    (arguments
-     `(#:configure-flags (list (string-append
-                                "--with-sqlite3="
-                                (assoc-ref %build-inputs "sqlite")))))
-    (synopsis "APL interpreter")
-    (description
-     "GNU APL is a free interpreter for the programming language APL.  It is
+  (let ((revision 1550))
+    (package
+      (name "apl")
+      (version (string-append "1.8-r" (number->string revision)))
+      (source
+       (origin
+         (method svn-fetch)
+         (uri (svn-reference
+               (url "svn://svn.savannah.gnu.org/apl/trunk")
+               (revision revision)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1bgc3a09f35zrqq2irhm1hspppnxjqas0fmcw14hkc7910br9ip3"))))
+      (build-system gnu-build-system)
+      (home-page "https://www.gnu.org/software/apl/")
+      (inputs
+       (list gettext-minimal
+             lapack
+             pcre2
+             readline
+             sqlite))
+      (arguments
+       (list #:configure-flags #~(list (string-append
+                                        "--with-sqlite3="
+                                        #$(this-package-input "sqlite")))
+             #:phases
+             #~(modify-phases %standard-phases
+                 (add-before 'configure 'fix-configure
+                   (lambda _
+                     (substitute* "buildtag.sh"
+                       ;; Don't exit on failed SVN-related calls.
+                       (("^ +return 0\n") "")
+                       ;; Manually set the SVN revision, since the directory is
+                       ;; unversioned and we know it anyway.
+                       (("^SVNINFO=.*")
+                        (string-append "SVNINFO=" #$(number->string revision) "\n"))
+                       ;; Requires running ‘svn info’ on a versioned directory.
+                       (("\\\\\"\\$ARCHIVE_SVNINFO\\\\\"") "\\\"\\\"")))))))
+      (synopsis "APL interpreter")
+      (description
+       "GNU APL is a free interpreter for the programming language APL.  It is
 an implementation of the ISO standard 13751.")
-    (license gpl3+)))
+      (license license:gpl3+))))