summary refs log tree commit diff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 8978b4e087..acbe9d9fdb 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -47,7 +47,6 @@
   (package
     (name "aspell")
     (version "0.60.8")
-    (replacement aspell/replacement)
     (source
      (origin
       (method url-fetch)
@@ -56,7 +55,8 @@
       (sha256
        (base32
         "1wi60ankalmh8ds7nplz434jd7j94gdvbahdwsr539rlad8pxdzr"))
-      (patches (search-patches "aspell-default-dict-dir.patch"))))
+      (patches (search-patches "aspell-default-dict-dir.patch"
+                               "aspell-CVE-2019-25051.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -93,16 +93,6 @@ documents written in the UTF-8 encoding and its ability to use multiple
 dictionaries, including personal ones.")
     (license lgpl2.1+)))
 
-;; Replacement package with security fixes.
-(define aspell/replacement
-  (package
-    (inherit aspell)
-    (source
-     (origin
-       (inherit (package-source aspell))
-       (patches (append (origin-patches (package-source aspell))
-                        (search-patches "aspell-CVE-2019-25051.patch")))))))
-
 ;;;
 ;;; Dictionaries.
 ;;;