summary refs log tree commit diff
path: root/gnu/packages/attr.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/attr.scm')
-rw-r--r--gnu/packages/attr.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index 2ce50296ac..3108a9072a 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -69,17 +69,13 @@
                                 ;; dependent on the underlying file system.
                                 #t)
                               %standard-phases))))))
-    (inputs `(;; Perl is needed to run tests; remove it from cross builds.
-              ,@(if (%current-target-system)
-                    '()
-                    `(("perl" ,perl)
-                      ("gettext" ,guix:gettext)))))
-    (native-inputs
-     ;; FIXME: Upon next core-updates, make gettext a native input
-     ;; unconditionally.
+    (inputs
+     ;; Perl is needed to run tests; remove it from cross builds.
      (if (%current-target-system)
-         `(("gettext" ,guix:gettext))
-         '()))
+         '()
+         `(("perl" ,perl))))
+    (native-inputs
+     `(("gettext" ,guix:gettext)))
 
     (home-page "http://savannah.nongnu.org/projects/attr/")
     (synopsis "Library and tools for manipulating extended attributes")