summary refs log tree commit diff
path: root/gnu/packages/autogen.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/autogen.scm')
-rw-r--r--gnu/packages/autogen.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index d0e4f2f34c..9751e11a64 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -73,6 +73,13 @@
                (("#elif GUILE_VERSION < 203000") "#elif GUILE_VERSION < 301000"))
              (substitute* "configure"
                (("2.2 2.0 1.8") "3.0 2.2 2.0 1.8"))))
+         (add-after 'unpack 'use-numeric-ids-in-tarball
+           ;; Pass arguments to tar to generate tarball with consistent uid
+           ;; and gid to ensure reproducible build
+           (lambda _
+             (substitute* "pkg/libopts/mklibsrc.sh"
+               (("--sort=name --format=gnu")
+                "--sort=name --format=gnu --owner=0 --group=0 --numeric-owner"))))
          (add-before 'build 'set-man-page-date
            ;; Avoid embedding the current date for reproducible builds
            (lambda _