summary refs log tree commit diff
path: root/gnu/packages/aux-files/guix.vim
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aux-files/guix.vim')
-rw-r--r--gnu/packages/aux-files/guix.vim8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
index 7dc359e52b..9397c53701 100644
--- a/gnu/packages/aux-files/guix.vim
+++ b/gnu/packages/aux-files/guix.vim
@@ -1,7 +1,13 @@
 " This appends all of the vim plugins to the end of Vim's runtimepath.
-for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
+for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $HOME ."/.guix-home/profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
     let vimplugins = directory . "/share/vim/vimfiles"
     if isdirectory(vimplugins)
         let &rtp = join([&rtp,vimplugins], ',')
     endif
 endfor
+" Unconditionally add */after directories last, as intended by upstream
+" TODO: Remove duplicate */after directories
+for directory in [$VIM . "/vimfiles", $HOME ."/.vim"]
+    let vimplugins = directory . "/after"
+    let &rtp = join([&rtp,vimplugins], ',')
+endfor