summary refs log tree commit diff
path: root/gnu/packages/axoloti.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/axoloti.scm')
-rw-r--r--gnu/packages/axoloti.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/axoloti.scm b/gnu/packages/axoloti.scm
index 0b12e4fe29..c6dd748773 100644
--- a/gnu/packages/axoloti.scm
+++ b/gnu/packages/axoloti.scm
@@ -125,6 +125,11 @@
                (("arm-none-eabi-(gcc|g\\+\\+|objcopy|objdump)" tool)
                 (which tool)))
 
+             ;; XXX: for some reason the whitespace substitution does not
+             ;; work, so we disable it.
+             (substitute* "firmware/Makefile.patch"
+               (("^BDIR=.*") "BDIR=${axoloti_home}/build\n"))
+
              ;; Hardcode full path to compiler tools
              (substitute* '("firmware/Makefile"
                             "firmware/flasher/Makefile"