summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9884f58fc3..ca880d6c05 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -105,6 +105,15 @@
              (substitute* "duplicity/gpginterface.py"
                (("self.call = 'gpg'")
                 (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
+
+             ;; This matches up with an unreleased upstream fix, it should be
+             ;; removed when the package is updated
+             ;; https://bazaar.launchpad.net/~duplicity-team/duplicity/0.8-series/revision/1308
+             (substitute* "duplicity/gpg.py"
+               (("--no-secmem-warning'\\)")
+                "--no-secmem-warning')
+        gnupg.options.extra_args.append('--ignore-mdc-error')"))
+
              (substitute* '("testing/functional/__init__.py"
                             "testing/overrides/bin/lftp")
                (("/bin/sh") (which "sh")))
@@ -485,8 +494,21 @@ detection, and lossless compression.")
        (modules '((guix build utils)))
        (snippet
         '(begin
+           ;; Delete files generated by Cython.  We used to have a regex
+           ;; that created the list of generated files but Borg has
+           ;; added new non-generated C files that cause the regex to
+           ;; generate the wrong list.
            (for-each delete-file
-                     (find-files "borg" "^(c|h|p).*\\.c$"))
+                     '("src/borg/algorithms/checksums.c"
+                       "src/borg/chunker.c"
+                       "src/borg/compress.c"
+                       "src/borg/crypto/low_level.c"
+                       "src/borg/hashindex.c"
+                       "src/borg/item.c"
+                       "src/borg/platform/darwin.c"
+                       "src/borg/platform/freebsd.c"
+                       "src/borg/platform/linux.c"
+                       "src/borg/platform/posix.c"))
            ;; Remove bundled shared libraries.
            (with-directory-excursion "src/borg/algorithms"
              (for-each delete-file-recursively
@@ -853,6 +875,15 @@ is like a time machine for your data. ")
                                         ,version)
                (invoke "go" "run" "build.go"))))
 
+         (replace 'check
+           (lambda _
+             (with-directory-excursion (string-append
+                                        "src/github.com/restic/restic-"
+                                        ,version)
+               ;; unexpected error: fusermount: exit status 1
+               (delete-file "cmd/restic/integration_fuse_test.go")
+               (invoke "go" "run" "build.go" "--test"))))
+
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))