summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f043f8233c..00571a8318 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -249,7 +249,12 @@ used to apply commands with arbitrarily long arguments.")
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)                        ;bignums in 'expr', yay!
-             ("libcap" ,libcap)))    ;capability support is 'ls','dir', 'vdir'
+
+             ;; Drop the dependency on libcap when cross-compiling since it's
+             ;; not quite cross-compilable.
+             ,@(if (%current-target-system)
+                   '()
+                   `(("libcap" ,libcap)))))  ;capability support is 'ls', etc.
    (native-inputs
     ;; Perl is needed to run tests in native builds, and to run the bundled
     ;; copy of help2man.  However, don't pass it when cross-compiling since