summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e2c4408edd..10b7361b38 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -357,6 +357,7 @@ used to apply commands with arbitrarily long arguments.")
               (list (string-append "XFAIL_TESTS=tests/misc/env-S.pl"
                                    " tests/misc/kill.sh"
                                    " tests/misc/nice.sh"
+                                   " tests/misc/pwd-long.sh"
                                    " tests/split/fail.sh"
                                    " test-fdutimensat"
                                    " test-futimens"
@@ -574,8 +575,8 @@ included.")
 ;; big refactoring of xtensa-modules.c (commit 567607c11fbf7105 upstream).
 ;; Keep this version around until the patch is updated.
 (define-public binutils-2.33
-  (package/inherit
-   binutils
+  (package
+   (inherit binutils)
    (version "2.33.1")
    (source (origin
              (inherit (package-source binutils))
@@ -590,8 +591,7 @@ included.")
    (properties '())))
 
 (define-public binutils-gold
-  (package
-    (inherit binutils)
+  (package/inherit binutils+documentation
     (name "binutils-gold")
     (arguments
      `(#:phases