summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5674036318..bf6435585e 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -415,7 +415,13 @@ used to apply commands with arbitrarily long arguments.")
                      ,@(if (hurd-target?)
                            '((substitute* "Makefile.in"
                                ;; this test hangs
-                               (("^ *tests/misc/timeout-group.sh.*") "")))
+                               (("^ *tests/misc/timeout-group.sh.*") ""))
+                             (substitute* "gnulib-tests/Makefile.in"
+                               ;; This test sometimes fails and sometimes
+                               ;; passes, but it does this consistently, so
+                               ;; there might be some environmental factor
+                               ;; here
+                               ((" test-tls\\$\\(EXEEXT\\) ") " ")))
                            '())
                      (substitute* "Makefile.in"
                        ;; fails on filesystems where inotify cannot be used,