summary refs log tree commit diff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index cfa037dec0..db01d1a7e2 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
@@ -37,8 +37,11 @@
    (version "8.0.6")
    (source (origin
             (method url-fetch)
-            (uri (string-append "https://github.com/ivmai/bdwgc/releases"
-                                "/download/v" version "/gc-" version ".tar.gz"))
+            (uri (list (string-append "https://github.com/ivmai/bdwgc/releases"
+                                      "/download/v" version
+                                      "/gc-" version ".tar.gz")
+                       (string-append "https://www.hboehm.info/gc/gc_source"
+                                      "/gc-" version ".tar.gz")))
             (sha256
              (base32
               "04ga3c95w5az5sznzm73j19lvvfpf6k4sgkpjqsmjxpsr6mi8j9v"))))
@@ -71,6 +74,9 @@
         (list libatomic-ops)
         '()))
    (outputs '("out" "debug"))
+   (properties
+    '((release-monitoring-url . "https://www.hboehm.info/gc/gc_source/")
+      (upstream-name . "gc")))
    (synopsis "The Boehm-Demers-Weiser conservative garbage collector
 for C and C++")
    (description