summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb12eba7c5..a986e118f8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9667,6 +9667,78 @@ includes software to
 ")
       (license license:cc0))))
 
+(define-public r-demultiplex2
+  (let ((commit "e42bc8310c0ea035af100e6ccea59b46ad6385f5")
+        (revision "1"))
+    (package
+      (name "r-demultiplex2")
+      (version (git-version "1.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/Gartner-Lab/deMULTIplex2")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "15f3kshsdvm97w24ql9b1wjlfbabimdsam0482hg7jivlvpl8j9w"))))
+      (properties `((upstream-name . "deMULTIplex2")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-data-table
+                               r-devtools
+                               r-dplyr
+                               r-ggextra
+                               r-ggplot2
+                               r-gridextra
+                               r-magrittr
+                               r-mass
+                               r-matrix
+                               r-rcolorbrewer
+                               r-shortread
+                               r-stringdist
+                               r-tidyr
+                               r-uwot
+                               r-viridis
+                               r-xvector))
+      (home-page "https://github.com/Gartner-Lab/deMULTIplex2")
+      (synopsis "Robust sample demultiplexing for scRNA-seq")
+      (description
+       "This package implements a bioinformatics algorithm for demultiplexing
+multiplexed single cell datasets.  It is built on a statistical model of tag
+read counts derived from the physical mechanism of tag cross-contamination.")
+      (license license:cc0))))
+
+(define-public r-demuxmix
+  (let ((commit "09a7918ca6e0cd23e6bbaed2b97388bc499e248e")
+        (revision "1"))
+    (package
+      (name "r-demuxmix")
+      (version (git-version "1.1.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/huklein/demuxmix")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "03kfnns7m2447jsc3xplyv9qx8hvvdjmii7j837g3bb6smyxss96"))))
+      (properties `((upstream-name . "demuxmix")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-ggplot2 r-gridextra r-mass r-matrix))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/huklein/demuxmix")
+      (synopsis
+       "Demultiplexing oligo-barcoded scRNA-seq data using regression mixture models")
+      (description
+       "This package is used for demultiplexing single-cell sequencing
+experiments of pooled cells.  These cells are labeled with barcode
+oligonucleotides.  The package implements methods to fit regression mixture
+models for a probabilistic classification of cells, including multiplet
+detection.  Demultiplexing error rates can be estimated, and methods for
+quality control are provided.")
+      (license license:artistic2.0))))
+
 (define-public gdc-client
   (package
     (name "gdc-client")